Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Make your likes visible on Facebook?

Connect your Facebook account to Prezi and let your likes appear on your timeline.
You can change this under Settings & Account at any time.

No, thanks

Entornos de desarrollo y requerimientos de los dispositivos ligeros

Desarrollo de aplicaciones para dispositivos moviles
by

Diana López

on 14 February 2017

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of Entornos de desarrollo y requerimientos de los dispositivos ligeros

Entornos
de desarrollo

Requerimientos
¿Que es un entorno de desarrollo (IDE)?
NetBeans
NeatBeans es un entorno de desarrollo integrado libre y gratuito, hecho principalmente para el lenguaje de programación Java.

La plataforma NetBeans permite que las aplicaciones sean desarrolladas a partir de un conjunto de componentes de software llamados módulos.
Un IDE es un entorno de programación que ha sido empaquetado como un programa de aplicación.
Algunas de estas plataformas son:

Entornos de desarrollo
Requerimientos de Windows Phone
Requerimientos para
iOS
Requerimientos
de hardware para Android

• 800 MHz procesador
• 1 GB RAM
• 1024 x 768 resolución de pantalla
• Herramientas desarrolladoras de Android
(el plug-in de Eclipse)
• Instalar el Android SDK
Es el entorno de desarrollo integrado (IDE, en sus siglas en inglés)de Apple Inc. y se suministra gratuitamente junto con Mac OS X.

Entornos de desarrollo y requerimientos de los dispositivos ligeros

DESARROLLO DE APLICACIONES
PARA DISPOSITIVOS MÓVILES

Eclipse es un programa informático compuesto por un conjunto de herramientas de programación de código multiplataforma para desarrollar lo que el proyecto llama "Aplicaciones de Cliente Enriquecido".
La sintaxis del lenguaje de programación Java deriva mucho de C y C++, pero tiene menos facilidades de bajo nivel que cualquiera de ellos. Las aplicaciones de Java son compiladas generalmente a bytecode (clase java) que pueden ejecutarse en cualquier máquina virtual Java (JVM) sin importar la arquitectura de la computadora subyacente.

Es un lenguaje de programación de propósito general, concurrente, orientado a objetos y basado en clases que fue diseñado específicamente para tener tan pocas dependencias de implementación como fuera posible.
Es una herramienta para el desarrollo de software en lenguaje c++ destinada a dispositivos que funcionan bajo Symbian OS. Se usa tanto para desarrollar los teléfonos que incorporan OS como para las aplicaciones que ejecutan estos.
CARBIDE C++
XCODE
XCODE trabaja conjuntamente con interface Builder, una herencia NeXT, una herramienta gráfica para la creación de interface de usuario.
Se refiere a las necesidades y requerimientos que el usuario puede llegar a tener y que se les pedirán a la aplicación.
Requerimientos de los dispositivos ligeros:
• NetBeans
• Eclipse
• Java
• Carbide. C++
• XCODE
Por ejemplo, en el caso de un análisis para una aplicación que se ejecutara en un dispositivo móvil, algunos de los requerimientos generales pueden ser, la facilidad de uso y que se pueda ejecutar en teléfonos móviles.
Requerimientos de Symbian
Para la programación de aplicaciones se pueden utilizar distintos lenguajes:

Visual Basic, Java, OPL y C++.


Siendo este último el lenguaje nativo de Symbian y el que proporciona acceso a un mayor número de funcionalidades. Existen diferentes SDKs (Software Development Kit) para el desarrollo.

Requisitos de hardware:
• 6.5 GB libres en el disco duro
• 4 GB en memoria RAM minimo

Requisitos de software:
• Windows 8 Pro en su versión de 64 bits
• SDK de Windows Phone 8

• Mac OS X 10.6 (Snow Leopard) o posterior
• iOS SDK 5.0 o posterior
• Dispositivo móvil para pruebas (opcional)

El iOS SDK contiene el código, la información y las herramientas necesarias para desarrollar, probar, ejecutar, depurar y ajustar las apps para el iOS.
Full transcript