Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Make your likes visible on Facebook?

Connect your Facebook account to Prezi and let your likes appear on your timeline.
You can change this under Settings & Account at any time.

No, thanks

PSEUDOCODIGOS 2014

TERCERO A-B-C
by

Jorge Gonzalez Haro

on 28 April 2014

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of PSEUDOCODIGOS 2014

LOS PSEUDOCODIGOS
El pseudocódigo conocido también como PSEUDOLENGUAJE (Falso lenguaje) es un lenguaje de especificación de algoritmos que utiliza palabras reservadas de un idioma y exige la Identación, o sangría en el margen izquierdo, de algunas líneas.
El pseudocódigo se utiliza para superar las dos principales desventajas del diagrama de flujo: lento de crear y difícil de modificar sin un nuevo redibujo.

El pseudocódigo es un lenguaje que permite la descripción de algoritmos utilizando palabras reservadas del idioma Español, considerando la lógica y las estructuras de un lenguaje de programación estructurado.
Las principales características de este lenguaje son: 
1. Se puede ejecutar en un ordenador.
2. Es una forma de representación sencilla de utilizar y de manipular.
3. Facilita el paso del programa al lenguaje de programación estructurados como: C/C++, Java, Visual Basic, etc. .
4. Es independiente del lenguaje de programación que se vaya a utilizar.
5. Es un método que facilita la programación y solución al algoritmo del programa.



Reglas para elaborar pseudocódigos:

1. Se empieza con la palabra algoritmo seguido del nombre del objetivo del problema a resolverse.
2. Se especifican las constantes, tipos de datos y variables a utilizarse.
3. El cuerpo del pseudocódigo comienza con la palabra inicio y terminará con la palabra fin.
4. Se debe utilizar sangrías al margen izquierdo de las instrucciones.
5. Se utiliza el símbolo:
//
para situar comentarios en una sola línea.
6. Se utiliza el símbolo:
{ }
para colocar comentarios de varias líneas.
7. Para almacenar en una variable el resultado de evaluar una expresión se utiliza flecha izquierda(
<-
) de la siguiente manera.
<nombre de variable><- <expresion>
8. Para introducir un valor o serie de valores desde el dispositivo estándar y almacenar en una o varias variables utilizaremos el verbo
leer (<lista de variables>).
9. Para imprimir en el dispositivo estándar de salida una o varias variables emplearemos el verbo
escribir (<lista de variables>).


FORMATO DE UN PSEUDOCODIGO.

algoritmo
nombre_algoritmo
[const <declaraciones de constantes>]
[tipo <declaraciones de tipos de datos>][variables <declaraciones de variables>]
inicio
instrucción 1
instrucción 2
instrucción 3
…………………
instrucción n
fin

ESTRUCTURAS DE CONTROL
a) Secuencial

inicio
acción 1
acción 2
acción 3
…………………
acción n
fin

Selectiva simple

si
<condición>
entonces
<acciones 1>
fin_si

Selectiva doble
si
<condición>
entonces
<acciones 1>
si_no
<acciones 2>
fin_si

Repetitivas
mientras
<condición>
hacer
<acciones>
fin_mientras
repetir
<acciones>
mientras
<condición>


para

<variables>

<-

<v_inicial>
hasta

<v-final>
[incremento | decremento]
hacer
fin_para
Las palabras inicio, fin, leer, escribir y las otras que aparecen en negrita y color azul en las distintas estructuras se consideran palabras reservadas.

PALABRAS RESERVADAS

Las palabras reservadas en el desarrollo de algoritmos utilizando pseudocódigos se escribirán en minúsculas y en negritas.

EJERCICIOS RESUELTOS
Ejercicio 1:
Escribir un algoritmo en pseudocódigo para calcular la superficie de un triangulo, introduciendo como datos la base y la altura.

algoritmo
superficie_triángulo
variables
base, altura: entero
superficie: real
inicio
leer (base,altura)
superficie
<-

(base*altura)/2
escribir(superficie)
fin

EJERCICIOS RESUELTOS
Ejercicio 2:
Se introduce por teclado dos números. Elaborar un algoritmo en pseudocódigo para averiguar cual es el mayor e imprimir.

algoritmo
mayor_numero

variables
num1, num2, mayor: entero
inicio

leer
(num1, num2)

si
num1 > num2
entonces
mayor
<-
num1

si_no
mayor
<-
num2
fin_si

escribir
(mayor)
fin
DEFINICON DE TERMINOS
CARACTERISTICAS DE LOS PSEUDOCODIGOS
3. Realizar el pseudocódigo de un programa que permita calcular el área de un rectángulo. Se debe introducir la base y la altura para poder realizar el cálculo, imprime en pantalla el área.
algoritmo
area_rectangulo

variables
base, altura, area: entero
inicio
Escribir "Ingrese la base: ";
leer
base;
Escribir "Ingrese la altura: ";
leer
altura;
area<-base*altura;
escribir
"El área del rectángulo es: ", area;
fin
WEBGRAFIA:
Informática Integral 3: Jorge Navarrete.
http://www.slideshare.net/
http://www.slideshare.net/IvanVeraMontenegro/diagramas-de-flujo-especificaciones-y-diseo-de-procesos
http://es.wikipedia.org/wiki/Diagrama_de_Flujo_de_Datos
http://www.slideshare.net/juangui1989/problemas-1-al-7-diagrama-de-flujo-problema-7-y-pseudocdigo-y-diagrama-de-flujo-para-el-problema-de-leer-tres-notas-del-alumno

http://startingtoprogram.blogspot.com/2011/07/pseudocodigo-003-sumar-dos-enteros.html
Ingrese a este url para practicar sobre Pseudocódigos:
http://www.daypo.com/test-algoritmos-diagramas-flujo-pseudocodigos.html
http://www.creartest.com/hacertests-78782-EXAMEN_LOGICA_COMPUTACIONAL.php

WEBGRAFIA:

INFORMÁTICA INTEGRAL 3: Jorge Navarrete.
www.slideshare.net/‎
http://www.slideshare.net/CarlosBez/tutorial-p-seint-15734467?qid=039a4612-0989-40af-910b-4bd9030ac31d&v=qf1&b=&from_search=2
http://www.slideshare.net/ClaudioCruz8/pseudocodigo-1-33144997?qid=039a4612-0989-40af-910b-4bd9030ac31d&v=qf1&b=&from_search=6
http://www.slideshare.net/grachika/tutorial-de-pseudocodigos?qid=039a4612-0989-40af-910b-4bd9030ac31d&v=qf1&b=&from_search=12
Ingrese a este link para ver algunos ejemplos:
Full transcript