Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Make your likes visible on Facebook?

Connect your Facebook account to Prezi and let your likes appear on your timeline.
You can change this under Settings & Account at any time.

No, thanks

Estrutura de Repetição

comando "PARA"
by

Gustavo Castello

on 20 April 2016

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of Estrutura de Repetição

ALGORITMO “Repete frase”
INICIO
escreval ("Bem Vindo a Aula de Lógica.")
escreval ("Bem Vindo a Aula de Lógica.")
escreval ("Bem Vindo a Aula de Lógica.")
escreval ("Bem Vindo a Aula de Lógica.")
escreval ("Bem Vindo a Aula de Lógica.")
FIMALGORITMO


Levando em consideração o que aprendemos até o momento, o algoritmo está correto.
Obstacle 1
Utilizando
Repetição

Pseudocódigo
Start
Você já sabe que alguns algoritmos precisam executar instruções com base em uma condição pré-estabelecida. Nas estruturas de decisão que vimos nas aulas anteriores, se uma condição é verdadeira, um comando ou grupo de comandos é executado. Após isso, a estrutura é finalizada. Ou há o caminho alternativo, caso a condição não seja atendida.
Nas estruturas de repetição, condições também são testadas. Mas, o que, de fato, caracteriza essa estrutura é que um conjunto de ações é executado de forma repetida enquanto a condição permanece válida ou não.
algoritmo "Repete frase"
var
contador : inteiro
inicio
para contador de 1 ate 5 passo 1 faca
escreval ("Bem Vindo a Aula de Lógica.")
fimpara
fimalgoritmo

algoritmo "Calcula Média com Repetição"
var
nota1, nota2, media : real
contador : inteiro
controle : inteiro
inicio
para contador de 1 ate 50 passo 1 faca
escreval ("Digite as notas do aluno ",contador,":")
escreval ("Primeira nota:")
leia (nota1)
escreval ("Segunda nota:")
leia (nota2)
media <- (nota1+nota2)/2
escreval ("O aluno ",contador," teve média igual a: ",media)
fimpara
Fimalgoritmo
Estruturas de Repetição
comando "PARA"
Exemplo
para <variável inteiro> de <valor inicial> ate <valor final> passo <valor de incremento> faca
<instruções>
fimpara
OU
para <variável inteiro> de <valor inicial> ate <valor final>faca
<instruções>
fimpara
Estrutura de Repetição
faça um algoritmo que escreva cinco vezes a frase:
“Bem vindo a Aula de Lógica”
No algoritmo acima, criamos uma variável de controle (contador) que é quem determina quantas vezes o comando escreval será executado. A repetição só para quando a condição não for mais atendida, ou seja, quando o contador for maior que 5.
ALGORITMO PARA CALCULAR A MÉDIA ARITMÉTICA ENTRE DUAS NOTAS PARA 50 ALUNOS DE UMA SALA
Full transcript