Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Make your likes visible on Facebook?

Connect your Facebook account to Prezi and let your likes appear on your timeline.
You can change this under Settings & Account at any time.

No, thanks

Diseño de una red inalambrica comunitaria del tipo mesh para

No description

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of Diseño de una red inalambrica comunitaria del tipo mesh para

CAUSAS
PROBLEMA
EFECTOS
OBJETIVO GENERAL
Diseñar una red inalámbrica comunitaria de tipo mesh en el municipio de Tebicuary permitiendo el acceso libre a Internet mediante el uso de las TIC y montar aplicaciones sobre la misma de manera a contribuir con la disminución de la brecha digital existente en el Paraguay.
CONTENIDO
INTRODUCCIÓN
OBEJTIVOS
FINALIDAD
MARCO TEÓRICO
PROPUESTA DE DISEÑO
ANÁLISIS ECONÓMICO
CONCLUSIONES
RECOMENDACIONES

FINALIDAD
Precio elevado de los planes de acceso a Internet
La población pierde grandes oportunidades de crecimiento económico.
Se desaprovecha el ancho de banda disponible del backbone nacional
OBJETIVOS ESPECÍFICOS
Realizar un análisis del perfil del terreno del Municipio de Tebicuary.
Evaluar los requisitos de software y hardware necesarios para el diseño de la red comunitaria.
Realizar simulaciones para evaluar la factibilidad técnica del proyecto.
Diseñar servicios sobre la red que esten al servicio de los ciudadanos.
Realizar un análisis de factibilidad económica para la implementación de la red.
LA BRECHA DIGITAL
El estándar IEEE 802.11
Clasificación de las redes inalámbricas
Redes de infraestructura
Redes Ad-Hoc
Funciones del enrutamiento
Descubrimiento de nodos
Clasificación de los protocolos de enrutamiento de las redes mesh
Protocolo B. A. T. M. A. N.
Diseñado por la comunidad wireless Freifunk
Ventajas de las redes Mesh
PROPUESTA DE DISEÑO
Selección del área de cobertura
Área de cobertura seleccionada
Ejecución del Site survey
Cantidad de señales recibidas en la banda de 2.4GHz y 5GHz.
Cálculo de la capacidad de conexión de la red
Datos Relevantes
Cálculo del ancho de banda requerido
Mensajes de texto y correo
Navegación Web
Contenido multimedia
Ubicación de los nodos mesh
Existencia de columnas de ANDE
Ubicación de los nodos mesh
Ubicación del gateway
Área de cobertura
Configuración de las unidades mesh
Parámetros de la red 2.4GHz
Parámetros de la red 5GHz
Parámetros de sistema 5GHz
Plot de Cobertura Red 2.4GHz
Plot de Cobertura Red 5GHz
Diagrama esquemático de la red
ISP: Proveedor de servicios de Internet
MR: Enrutador Mesh
Enlace Inalámbrico
Enlace F. O.
Equipos a implementar en el sistema propuesto
Router Inalámbrico
Operación Dual Band 2.4 y 5 GHz
Ancho de banda de 150Mbps
Bajo costo
Capacidad de modificación de firmware
Transceivers, conectores y antenas
Modificación del firmware de los nodos mesh
Página de administración del firmware original
Página de administración del firmware openwrt
Configuración de la red
Distribución de direcciones IP
Interfaz de administración
Estado de interfaces
Estado interfaces nodo principal
Estado interfaces nodo secundario
Estado de redes wireless
Diseño de página de bienvenida
Página de bienvenida
Configuración
Nodogsplash
Página Web de la Municipalidad
Servidor FTP de contenidos
Contenidos disponibles en servidor FTP
Configuración Servidor FTP
Análisis Económico
Costo de la planificación e ingeniería del diseño del sistema
Tiempo de planificación e ingeniería del diseño
: 1 mes (120h);

Tiempo de programación del software
: 1 mes (120h);

Sueldo promedio hora/hombre de un ingeniero junior en electrónica
: 25 USD;


Cantidad de personas a cargo del proyecto
: 2 ingenieros junior.
Tiempo empleado en planificación y la ingeniería de de diseño
: 120 horas
Costo
: 120h x 25USD =3.000 USD.
Tiempo empleado en la programación y configuración del software
: 120 horas
Costo
: 120h x 25USD=3.000 USD.
Costo de la planificación e ingeniería del diseño del sistema
Costos de implementación del proyecto
Gastos de operación anual
Costos por usuario
Cálculo de cantidad de usuarios
3.100 Habitantes
70 % de la población es urbana
90% de la población urbana es cubierta por el proyecto
3.100x0,7x0,9 =
1.953 usuarios

Cálculo de costos por usuario
Costo de implementación
11.500/1.953 =
5
,88 USD
Costo de mantenimiento anual
23.063/1.953 =
11,8
USD
Conclusiones
Parámetros de sistema 2.4 GHz
Se realizó la simulación del área de cobertura comprobando la factibilidad técnica.
Recomendaciones
Implementar la gestión de múltiples gateway sobre la misma red mesh
Marco Teórico
INGENIERÍA EN ELECTRÓNICA

Énfasis en Teleprocesamiento de la Información
DISEÑO DE UNA RED INALÁMBRICA COMUNITARIA DEL TIPO MESH PARA DISMINUIR LA BRECHA DIGITAL EN EL MUNICIPIO DE TEBICUARY
Juan José Agüero Sánchez
Francisco Antonio Casaccia Torres

Tutores
Ing. César Duarte
Ing. Víctor Martínez

Fuente: Red Inalámbrica tipo malla (WMN) bajo el estándar 802.11 para la Universidad Internacional SEK. p. 109
Fuente: Red Inalámbrica tipo malla (WMN) bajo el estándar 802.11 para la Universidad Internacional SEK. p. 109
Fuente: Red Inalámbrica tipo malla (WMN) bajo el estándar 802.11 para la Universidad Internacional SEK. p 111.
Fuente: Mapa satelital extraido de Google Earth
Fuente: Realizado en el software Radio Mobile
Fuente: Datos y fórmula extraídos de Redes Inalámbricas en países en desarrollo. Butler, Jane 2013
Fuente: Fotografía tomada por los autores
Fuente: Fotografía tomada por los autores
Fuente: Fotografía tomada por los autores
Fuente: Fotografía tomada por los autores
Fuente: Mapa satelital extraído de Google Maps
Fuente: Software Radio Mobile
Fuente: Plot de cobertura elaborado en el software Radio Mobile
Fuente: Elaborado en el software Packet Tracer
Fuente: Página de administración del firmware original
Fuente: Página de administración del firmware Openwrt
Fuente: Interfaz de administración Luci de OpenWRT
Fuente: Interfaz Luci del OpenWRT
Fuente: Software Nodogsplash
Fuente: Línea de comandos OpenWRT
Fuente: Guía estándar para la creación de sitios web del Gobierno
Fuente: Software FileZilla
Fuente: Línea de comandos CentOS 7
Fuente: Elaborado por los autores
Fuente: Elaborado por los autores
El país queda desfasado tecnológicamente con respecto a los demás países
Transceivers
Fuente: http://www.conrad.com/ce/en/product/1284581
Fibra óptica
Antenas
Fuente: http://www.amazon.com/Directional-TL-WDR4300-TL-WR1043ND-TL-WR2543ND-WRZ-HP
Fuente: http://www.tp-link.com/ar/products/details/TL-WDR3500.html
8
10
10
16
17
18
19
15
20
21
22
24
25
26
28
29
30
31
32
33
34
36
37
39
41
42
44
45
46
47
48
49
50
51
52
53
11
Se evaluaron los requisitos de software y hardware para el diseño de la red comunitaria.
Se diseñaron servicios sobre la red comunitaria.
Nodo principal
Fuente: Interfaz Luci del OpenWRT
Junio, 2016
INTRODUCCIÓN
LA BRECHA DIGITAL EN PARAGUAY
INDICE DE DESARROLLO DE BANDA ANCHA (IDBA)
Instrumento Socieconómico
Evalúa el desarrollo de la Banda Ancha
65 Países estudiados
4 Pilares para la evaluación
Elabora un Ranking con los resultados
Fuente: Informe anual del Índice del Desarrollo de la Banda Ancha en América Latina y el Caribe
SITUACIÓN POR DEPARTAMENTO DE LA BRECHA DIGITAL EN PARAGUAY
Evolución del estándar 802.11
Fuente: http://www.anandtech.com/
Redes Inalámbricas
Enrutamiento en la redes Mesh
Requerimientos básicos de la red
Diseño de área de cobertura
Diseño de Firmware
Aplicaciones desarrolladas
10 Nodos Mesh
Gateway
Fuente: Plan Nacional de Telecomunicaciones 2016-2020
PORCENTAJE DE HOGARES CON ACCESO A INTERNET Y CON COMPUTADORAS
UBICACIÓN DE PARAGUAY EN EL RANKING IDBA
OBJETIVOS
Software para el diseño de cobertura
Radio Mobile
Software de distribución libre
Generación de gráficos a partir de datos de elevación
Algoritmo Longle-rice para cálculos de propagación
Firmware utilizado en los nodos mesh
Distribución de Linux
Capacidad de enrutamiento mesh
Barrera para el crecimiento económico.
Motivo de estudio de varias organizaciones.
Ingreso a la página de administración del firmware original
Ingresar en "System Tool"y "Firmware Upgrade"; luego cargar el archivo del nuevo firmware (Openwrt)
Fuente: Plan Nacional de Telecomunicaciones 2016-2020
MOTIVOS PARA EL LENTO DESARROLLO DE LA BANDA ANCHA
Precio elevado de los planes de banda ancha
Disminución lenta de los precios.
Ingresar a la página del nuevo firmware (Opewrt)
Falta de contenido al servicio de la población
Baja penetración de acceso a Internet
Baja penetración de computadoras por hogar
Carga del firmware Openwrt
Versión del Firmware Openwrt
Protocolo
B. A. T. M. A. N.
Better Approach to Mobile Ad-hoc Network
Funcionamiento del protocolo B. A. T. M. A. N.
Estructura de los paquetes OGM
Canales y Frecuencias
Banda de 2.4GHz IEEE802.11n
Redes Mesh
Facilidad de implementación
10 Nodos Mesh
1 Nodo con conexión de Gateway
Conexión de Gateway al ISP por F. O.
Fuente: http://electronicdesign.com
Fuente: Michael Gauthier, Wireless Networking in the Developing World
1
2
3
4
6
9
12
13
23
27
35
43
Banda de 5GHz IEEE802.11n
Ajuste preciso de cobertura
Flexibilidad de interconexión
Bajo costo de inversión
Aprovechamiento de infraestructuras existentes
Departamento de Guairá
Municipio de Tebicuary
Configuración del Dynamic Host Configuration Protocol (DHCP)
Configuración del Firewall
Descubrimiento de frontera
Cálculo de rutas
Gestión de la red troncal
Ningún nodo tiene la información completa de la topología de la red.
Se comparte el conocimiento de la topología entre los nodos
Almacena la mejor dirección para llegar a cada nodo
Red "priv": Rango de direcciones 10.201.201.0/24
Red "pub": Rango de direcciones 10.200.200.0/24
Red de aministración:Rango de direcciones 10.10.10.0/28
Caja de conexión para el router mesh
Fuente: http://es.data-alliance.net/
Nodo secundario
PRESENTACIÓN DE RESULTADOS
Fuente: Interfaz Luci del OpenWRT
Fuente: Software Radio Mobile
Fuente: Software Radio Mobile
Fuente: Software Radio Mobile
Fuente: Software Radio Mobile
Fuente: Plot de cobertura elaborado en el software Radio Mobile
Fuente: Interfaz Luci del OpenWRT
Spread Spectrum
Banda ISM (Industrial, Científica y médica) de 2.4 GHz y 5 GHz
Se logró diseñar un prototipo de red estable, y con la calidad suficiente.
Desarrollar un sistema de gestión centralizada de los nodos mesh
Nodo
Nodo
A
OGM
Nodo
B
OGM
OGM : Originator Messages
Nodos mesh
Clientes Mesh
Gateways
Protocolos de enrutamiento de las redes mesh
Basado en topología
Basado en posición
Reactivos
Proactivos
Municipio de Tebicuary
Red mesh comunitaria formado por 10 nodos
1 nodo Gateway
Conexión al ISP
Servicios locales
Descubrimiento de nodos en la red
Cálculo de rutas
Fuente: http://open-mesh.org
Banco Interamericano de Desarrollo
Organismo para la Cooperación y el Desarrollo Económico
5


Selección de equipos a implementar
Impulsar el desarrollo tecnológico.
Brindar herramientas al servicio de la población.
Generar nuevas fuentes de empleo.
Servir como referencia para investigaciones futuras.
Intensidad de las señales recibidas en las bandas de 2.4GHz y 5GHz.
Separación máxima de 250m
Posibles obstáculos cercanos
MUNICIPIO DE TEBICUARY
Creado por Ley Nº 3.469/2.008
Aproximadamente 3100 habitantes
Explotación de caña de azucar
Situado a 200 km de Asunción
Baja penetración de Internet y Computadoras
Proyectos de responsabilidad social
Configuración de archivos

Existen 18 Municipios dentro del Dpto.
Principal actividad económica: Sector Agrario
Cuenta con 260.000 habitantes
Baja penetración de computadoras e Internet
BREVE RESUMEN DEL CONTEXTO PROBLEMÁTICO
7
14
Fuente: Mapa satelital extraido de Google Earth
38
Conexión ad-hoc
Creación de Puntos de Acceso.
Creación de puentes.
Omnidireccionales
Ganancia de 5dBi
Fuente: BATISTE, A. 2011. Protocolos de encaminamiento en redes inalámbricas mesh: un estudio teórico y experimental.
Replicar la red mesh sobre otras comunidades
Se analizaron los costos de inversión y los costos anuales para la implementación
1000BASE-SX
Conectores SC
Multimodo OM2
Fuente: http://www.ebay.es

Fuente: Dirección General de Estadística, Encuestas y Censos.
Fuente: Dirección General de Estadística, Encuestas y Censos
config wifi-iface wmesh
option device radio1
option ifname mesh0
option network mesh
option mode adhoc
option ssid Tebicuary_mesh
option bssid '02:CA:FE:CA:CA:40'
config wifi-iface pub
option device radio0
option ifname pub0
option network pub
option mode ap
option encryption none
option ssid Tebicuary_pub
config wifi-iface priv
option device radio0
option ifname priv0
option network priv
option mode ap
option encryption psk-mixed
option ssid Tebicuary_priv
option key Tebiciudad
config interface pub
option ifname bat0.1
option type bridge
option proto static
option ipaddr 10.200.200.3
option netmask 255.255.255.0
config interface priv
option ifname bat0.2
option type bridge
option proto static
option ipaddr 10.201.201.3
option netmask 255.255.255.0
config dhcp pub
option interface pub
option sart 11
option limit 253
option leasetime 12h
config dhcp priv
option interface priv
option sart 11
option limit 253
option leasetime 12h
config forwarding
option src pub
option dst lan
config forwarding
option src priv
option dst lan
Configuración en los nodos mesh
Cálculo del enlace de F. O.
Gracias por su atención.
Datos
Distancia = 150m.
Att de fibra = 3.5dB/Km
Att máx= 5dB
Cálculo de pérdidas
Pérdida por atenuación = 0.525dB
Pérdidas por conectores = 2dB
Pérdidas por empalmes = 0dB
Margen optico = 2dB
Pérdidas totales = 0.525+2+2 = 4.525 dB
P. totales < Att máx
Enlace Factible
Full transcript