Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Concepto y características de algoritmos.

No description
by

Juan Tabora

on 12 February 2015

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of Concepto y características de algoritmos.

Los pasos para la resolución de un problema son:
Para llegar a la realización de un programa es necesario el diseño previo de un algoritmo, de
modo que sin algoritmo no puede existir un programa.
Los algoritmos son independientes tanto del lenguaje de programación en que se expresan
corno de la computadora que los ejecuta.
Diseño del algoritmo
Una computadora no tiene capacidad para solucionar problemas más que cuando se le proporcio­nan los sucesivos pasos a realizar.

Los problemas complejos se pueden resolver más eficazmente con la computadora cuando se
dividen en subproblemas que sean más fáciles de solucionar que el original.

La descomposición del problema original en subproblemas más simples y a continuación la
división de estos subproblemas en otros más simples que pueden ser implementados para su solu­ción en la computadora se denomina diseño descendente .
Las ventajas más importantes del diseño descendente son:
• El problema se comprende más fácilmente al dividirse en partes más simples denominadas módulos.

• Las modificaciones en los módulos son más fáciles.

• La comprobación del problema se puede verificar fácilmente.

Características de los algoritmos
• Un algoritmo debe ser preciso e indicar el orden de realización de cada paso.

• Un algoritmo debe estar bien definido. Si se sigue un algoritmo dos veces, se debe obtener el
mismo resultado cada vez.

• Un algoritmo debe ser finito. Si se sigue un algoritmo, se debe terminar en algún momento;
o sea, debe tener un número finito de pasos.
Concepto,Diseño y Escritura de algoritmos.
Es un conjunto prescrito de instrucciones o reglas bien definidas, ordenadas y finitas que permite realizar una actividad mediante pasos sucesivos que no generen dudas a quien deba realizar dicha actividad.
Algortimo

Escritura del algoritmo.
Como ya se ha comentado anteriormente, el sistema para describir ("escribir") un algoritmo consis­te en realizar una descripción paso a paso con un lenguaje natural del citado algoritmo.
Diseño de
un
algoritmo
Diseño
descendente
(1)
Refinamiento
por casos
(2)
-Herramienta
de programación
(3)
-diagrama de flujo
­- pseudocódigo
- diagrama N-S
Recordemos que un algoritmo es un método o conjunto de reglas para solucionar un problema. En cálculos
elementales estas reglas tienen las siguientes propiedades:

• deben ir seguidas de alguna secuencia definida de pasos hasta que se obtenga un resultado coherente,

• sólo puede ejecutarse una operación a la vez.
El flujo de control usual de un algoritmo es secuencial; consideremos el algoritmo que res­
donde a la pregunta:


¿Qué hacer para ver una película?
La respuesta es muy sencilla y puede ser descrita en forma de algoritmo general de modo si­milar a:

-ir al cine
-comprar una entrada (billete o ticket)
-ver la película
-regresar a casa
1.inicio
2. ver : la cartelera de cines en el periódico
3. si no proyectan "Harry Potter" entonces
3. decidir otra actividad
3.2. bifurcar al paso 7
si no
3.3. ir al cine
fin si
4. si hay cola entonces
4.1. ponerse en ella
4.2. mientras haya personas delante hacer
fin si
5. si hay localidades entonces
5.1. comprar una entrada
5.2. pasar a la sala
5.3. localizar la(s) butaca(s)
5.4. mientras proyectan la película hacer
5.4.1. ver la película
fin mientras
5.5. abandonar el cine
si no
5.6. refunfuñar
fin si
6. volver a casa
7. fin
Full transcript