Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Make your likes visible on Facebook?

Connect your Facebook account to Prezi and let your likes appear on your timeline.
You can change this under Settings & Account at any time.

No, thanks

CCNA 2

Mapa mental de CCNA 2
by

Héctor Daniel Aguirre Ochoa

on 17 November 2013

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of CCNA 2

CCNA 2
Introduccion al enrutamiento
y envio de paquetes
Los router son computadoras
Poseen:
CPU
RAM
ROM
conectar redes
Sirven para
proceso de arranque
1-ejecucion de post
2-carga de bootstrap
3-Ubicacion y carga de IOS
4-Ubicacion y carga de configuracion y entra a modo setup
Parametros de configuracion basica
Denominacion del router : Router(Config)# hostname name
constraseñas:
Router(Config)#enable secret password
Router(Config)# line console 0
Router(Config-line)# password password
Router(Config-line)#login
Router(Config-line)#line vty 0 4
Router(Config-line)#password
Router(Config-line)#login
Mesaje del dia:
Router(Config)# banner motd #mensaje#
Rutas conectadas
tipos de enrutamiento dinamico

-Protocolo de información de enrutamiento (RIP, Routing Information Protocol)
-Protocolo de enrutamiento de gateway interior (IGRP, Interior Gateway Routing Protocol)
-Protocolo de enrutamiento de gateway interior mejorado (EIGRP, Enhanced Interior Gateway Routing Protocol)
-Open Shortest Path First (OSPF)
-Intermediate-System-to-Intermediate-System (IS-IS)
-Protocolo de gateway fronterizo (BGP, Border Gateway Protocol)
Enrutamiento estatico
Conexiones
Los cables de conexión directa se usan para conectar:
Un switch a un router
Un switch a una PC
Un hub a una PC
Un hub a un servidor

Los cables de conexión cruzada se usan para conectar:
Un switch a otro switch
Una PC a otra PC
Una switch a un hub
Un hub a otro hub
Un router a otro router
Un router a un servidor
Examen de Interfaces
si al momento de ejecutar el comando show interfaces se nos muestra una interfaz "administrative down" significa que no funciona o que se encuentra apagada, pero si se encuentra activada y nos muestra el "line protocol down" significa que no se encuentra conectada
Configuración de una interfaz Ethernet
Para configurar una Interfaz ethernet en nuestro router se debe hacer lo siguiente
R1(config)#interface fastethernet 0/0
R1(config-if)#ip address 172.16.3.1 255.255.255.0
R1(config-if)#no shutdown

Mediante esto Le configuramos un Ip y mascara de subred a la interfaz y con el uso del "no shutdown" encendemos la interfaz
Configuración de una interfaz serial
Una interfaz serial se configura de la misma manera que una ethernet solo que en lugar de usar Interface FastEthernet0/0 utilizaremos interface serial0/0/0

R1(config)#interface serial 0/0/0
R1(config-if)#ip address 172.16.2.1 255.255.255.0
R1(config-if)#no shutdown
Configuración de enlaces seriales
Cuando se interconectan dos interfaces seriales se debe conectar el extremo DCE en un router y se le debe configurar la señal de temporización

Router(config-in)# clock rate 64000
Protocolo CDP
El protocolo CDP es una poderosa herramienta de monitoreo y resolución de problemas. Los administradores lo utilizan para recopilar informacion de los dispositivos cisco conectados directamente.

Para verificar los resultados:
show cdp neighbors
show cdp neighbors detail

Para desactivar el protocolo CDP
no cdp run -desactivacion global-
no cdp enable -desactivar en una interfaz-
Proposito y Sintaxis de ip route
El comando ip route nos permite establecer direccione estaticas
Sumarizacion de redes
La sumarizacion nos permite resumir subredes en una sola red, por ejemplo las redes 10.0.0.0/16, 10.1.0.0/16, 10.2.0.0/16, 10.3.0.0/16, 10.4.0.0/16, 10.5.0.0/16, hasta 10.255.0.0/16, pueden representarse con una sola dirección de red: 10.0.0.0/8.
Introduccion al entrutamiento dinamico
Clasificacion de enrutamiento dinamico
RIP
: un protocolo de enrutamiento interior vector distancia
IGRP
: el enrutamiento interior vector distancia desarrollado por Cisco (en desuso desde el IOS 12.2 y versiones posteriores)
OSPF
: un protocolo de enrutamiento interior de link-state
IS-IS
: un protocolo de enrutamiento interior de link-state
EIGRP
: el protocolo avanzado de enrutamiento interior vector distancia desarrollado por Cisco
BGP
: un protocolo de enrutamiento exterior vector ruta
Protocolo de enrutamiento con y sin clase
Los protocolos de enrutamiento con clase son aquellos que no envian informacion de la mascara de subred debido a que se maneja la misma en toda la red (RIPv1 e IGRP), los protocolos de entrutamiento con clase envian informacion de la mascara de subred debido a que se manejan diferentes en la red (RIPv2, EIGRP, OSPF, IS-IS y BGP. )
Convergencia
La convergencia se da cuando cada router posee las tablas de enrutamiendo de los demas
Metrica
El propocito de usar ena metrica consiste en que al momento de lograr la convergencia se debe seleccionar la ruta mas corta y esta se calcula dependiendo del protocolo de enrutamiendo, ya sea usando conteo de saltos o de ancho de banda
Conteo de saltos
: una métrica simple que cuenta la cantidad de routers que un paquete tiene que atravesar.
Ancho de banda
: influye en la selección de rutas al preferir la ruta con el ancho de banda más alto.
Carga
: considera la utilización de tráfico de un enlace determinado.
Retardo
: considera el tiempo que tarda un paquete en atravesar una ruta.
Confiabilidad
: evalúa la probabilidad de una falla de enlace calculada a partir del conteo de errores de la interfaz o las fallas de enlace previas.
Costo
: un valor determinado ya sea por el Cisco IOS o por el administrador de red para indicar la preferencia de una ruta. El costo puede representar una métrica, una combinación de las mismas o una política.
Distancia adminsitrativa
La distancia administrativa se utiliza cuando un router recibe una solicitud de otro protocolo de enrutamiento hasta otro diferente, la distancia administrativa le permite al route decidir por donde es preferible que envie la solicitud
Protocolo de enrutamiento vector distancia
Actualizacion Periodica: RIPv1 e IGRP
Muchos protocolos vector distancia utilizan las actualizaciones periodicas para mantener actualizadas la tablas de enrutamiento con la de los vecinos, estas actualizaciones se llevan acabo cada cierto tiempo, por ejemplo RIPv1 envia actualizaciones cada 30 segundos
Triggered Update
Los triggered updates son generados por RIP en el momento en el que la red sufre un cambio, este se da de manera inmediata sin importar si el temporizador aun no termina, la actualizacion informa a los routers vecinos el cambio, ya sea si cambio de estado, es inalcamzable o cuando se instala una nueva ruta en la tabla de enrutamiento
Fluctuacion de fase aleatoria
La fluctuacion de face aleatoria se da gracias a que IOS utiliza una variable llamada RIP_Jitter que se encarga de evitar la sincronizacion de actualizaciones añadiendo de un 0% a 15% al intervalo de actualizacion predeterminado
Loop
Un Loop es un problema que se da en las redes impiediendo que un paquet llegue a su destino, puede ser probocado por una mala configuracion de rutas estaticas o tablas de enrutamiento incongruntes
envenenamiento de ruta
El envenenamiento de una ruta consiste en que en un fallo el router envenena esa ruta marcandolo como inalcansabley de inmediato envia una actualizacion envenenada a los siguientes routers, esta es una forma de evitar los Loops
RIP version 1
Habilitar RIP
Para habilitar el protocolo de enrutamiento RIP se debe acceder el modo de configuracion global y despues ingresar "router rip"
Especificacion de redes
Una vez que nos encontramos el modo de configuracion del router rip se debe utilizar el comando "network" seguido la de red directamente conectada
Interfaz Pasiva
Es recomendable convertir una interfaz en pasiva para evitar que envie actualizaciones a lugares donde no se encuentran dispositivos RIP y asi evitar que se consuma el ancho de banda,para hacer esto se debe introducir el siguiente codigo en el modo de configuracion de router (RIP) "passive-interface -interfaze- -numero de interfaze-"
propagacion por la ruta predeterminada RIPv1
El uso del comando "default-information originate" permite al router crear informacion predeterminada mediante la propagacion de ruta predeterminada en RIP
VLSM y CIDR
Direccionamiento ip con clase
CIDR y sumarizacion de ruta
CIDR usa mascaras de longitud variable(VLSM) permitiendo asignar ip segun las necesidaddes del lugar en vez de hacerlo con clase, ademas de que permite la sumarizacion de redes
VLSM en accion
Una de las caracteristicas mas importantes de VLSM es que nos permite subdividir una red para crear nuevas redes
VLSM y Direccionamiento ip
El beneficio principal del direccionamiento sin clase es que se puede subdivivir una red muchas veces para crear muchas subredes,a diferencia del dir. con clase que solo nos permitiria la creacion de 256 sub redes
Calculo de sumarizacion de Ruta
RIPv2
LoopBack
La funcion principal de una interfaz Loopback es emular una interfaz fisica para podeer crear mas redes sin tener que agregar una interfaz fisica en el router
Interfaz nula
Nos permite la creacion de una ruta estatica que podra ser incluida en el RIP para poder usarla se debe usar el comando "ip route -red- -mascara de red- null0" y para que se pueda redistribuir a los demas routers se debe entrar a la configuracion de router rip y usar el comando "redistribute static"
Formato RIPv1 vs RIPv2
Para habilitar la version 2 de rip se debe entrar a la configuracion de router rip eh introducir el comand "version 2" y para desactivar la sumarizacion automatica se debe utilizar el comando "no auto-summary"
La tabla de enrutamiento
Rutas de nivel 1
Ruta final
La ruta final es una red conectada directamente y contiene:
Ip del siguiente salto
interfaz de salida (opcional)
Ruta de nivel 2
Las rutas de nivel 2 o secundarias es una red conectada directamente y contiene nuestra red real, contiene:
C - codigo de red conectada directamente
entrada de la ruta especifica
"is directly connected"
interfaz de salida
EIGRP
Origen
EIGRP nacio de la mejora de IGRP que fue creado para reemplazar a RIPv1 por su limitante del conteo de saltos, la mejora que se aplico a IGRP fue el uso del algoritmo dual, EIGRP no envia actualizaciones periodicas, en su lugar envia un "hello" para verificar el estado del dispositivo y solo envia actualizaciones encaso de que sea conectada una nueva interfaz o una se desconecte
Tipo de paquete RTP
El protocolo de transporte confieble(RTP) s utilizado por EIGRP para el envio y recepcion de mensaje EIGRP. Como EIGRP fue desarrollado como un protocolo de enrutamiento independiente de la capa de red no puede usar los protocolos tcp/ip, pero al igual que tcp y udp, rtp posee transporte confiable y no confieble, el primero consiste en el envio y espera de confirmacion de envio el segundo solo envia el paquete sin esperar ninguna respuesta
Protocolo de saludo
Antes de poder enviar mensaje el EIGRP debe conocer a sus vecinos por lo que envia un paquete de saludo, este paquete de saludo es enviado cada cierto tiempo , dependiendo de las caracteristicas de la red por ejemplo en redes rapidas se configura a 5 segundos y en redes lentas a 60 segundos, perouna vez enviado el paquete de saludo tiene tiempo de espera que es 3 veses el intervalo de saludo, si no recibe respuesta marca al dispositivo como desconectado
ID del proceso
EIGRP y OSPF usan el ID de proceso para representar una instancia del protocolo de enrutamiento respectivo que se ejecuta en el router.

Router(config)#router eigrp autonomous-system

ese numero ayudara a que el router reconosca a los demas que posean el mismo numero de ID
Wild Card
La wild card es lo inverso a una mascara de subred y nos sirve cuando no deseamos agregar todas las interfaces dentro de una red al habilitar el EIGRP, para hacer esto debemos conocer el Wildcard que el simplemtente la ruta 255.255.255.255-la mascara de subred el numero resultante sera nuestra wild card que usaremos en el comando "network -ip dispositivo- -wildcard-"
Metrica compuesta de EIGRP y valores K
Ajuste EIGRP
Protocolo de enrutamiento link-state
Introduccion al algoritmo SPF
El algoritmo se encarga de acumular costos a lo largo de cada ruta para poder seleccionar la mas corta, los costos son valores agregados de manera arbitraria
Ventajas
Cada router crea su propio
arbol topologico
Convergencia rapida
debido que saturan las interfaces con paquetes LSP sin incluir de donde se resicio el ultimo paquete
Actualizaciones desencadenadas por eventos
Diseño jerarquico
OSPF
Tipos de mensaje
intervalo de saludo y muerto
antes de que los vecinos puedan ser agregados deben estar de acuerdo en 3 aspectos:
tiempo de saludo
tiempo muerto
- que es el tiempo en segundos que tardara un router en declarar como desactivado al route
tipo de red
Activacion de OSPF
Para activar OSPf en un routernse debe ingresar el comando "router ospf -id-" donde la id puede ir de 1 a 65535, a diferencia que EIGRP no es necesario que la id coiscida con los demas routers
Comando Network
el comando nerwork para agre una red se utilizara de la siguiente manera:
network -ip de red- -wildcard- -id de area-

donde la id de area representa un grupo de routers que compartiran informacion link-state
ID de router
La id del router puede ser configurada con el comando "router-id -ip-" pero si no es configurada tomara de manera predeterminada la ip de la direccion loopback mas altapara modificar la id se debe utilizar el siguiente comando "clear ip ospf -id de proceso-"
Modificacion del costo
el comando para poder modificar el costo es
R1(config-if)#ip ospf cost 1562
Como elegir un DR y BDR
Para elegir un DR se busca el router con prioridad mas alta, para el BDR se selecciona el segundo con prioridad mas alta en caso de que las prioridades sean iguales se seleccionara la ID mas alta para interumpir la coneccion
como establecer la prioridad
La prioridad se establece mediante el comando
Router(config-if)#ip ospf priority -prioridad-

donde la prioridad puede ir de 1 a 255
Modificacion de intervalo de Saludo y muerte
Para la modificacion del intervalo de saludo se debe utilizar "Router(config-if)#ip ospf hello-interval -segundos-"
y para el de muerte "Router(config-if)#ip ospf dead-interval -segundos-"
Full transcript