Enabling Flash for Prezi Classic

This support page is about Prezi Classic. If you’re looking for help with Prezi Next, please click here.

If you want to edit your Prezi Classic presentation online, your browser needs to have Adobe Flash enabled. Some browsers require you to download or enable Adobe Flash Player before continuing to edit.

Note: Adobe Flash is not currently supported on iPad and other iOS devices.

If Adobe Flash is not in your list of plug-ins, please visit the Adobe Flash support page to download or troubleshoot Adobe Flash Player in your browser.

Want to create stunning presentations without Flash?

Times change, and so does technology. That’s why we’ve streamlined the best elements of Prezi Classic and added a host of new capabilities to our newest presentation platform, Prezi Next. Click here to learn all about creating next-level presentations that visually pop and captivate your audience.

Was this helpful?    

Thanks for the feedback!

Could this be better?  Yes, let me comment.

  Only our editor will see your comments.

Don’t see what you’re looking for?  Please log in to see the support options.