Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Make your likes visible on Facebook?

Connect your Facebook account to Prezi and let your likes appear on your timeline.
You can change this under Settings & Account at any time.

No, thanks

Aulas Lógica de programação - Dados Homogêneos

Apresentação para aula de lógica de programação focando em Dados homogêneos (vetores e matrizes).
by

Ythalo Rossy Saldanha Lira

on 5 November 2011

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of Aulas Lógica de programação - Dados Homogêneos

algoritmo "testandoVariaveis"

var
time : vetor[1..21] de caracter

inicio
time[1] <- "Taffarel (Reggiana)"
time[2] <- "Gilmar (Flamengo)"
time[3] <- "Jorginho (Bayern Munchen)"
time[4] <- "Cafu (São Paulo)"
...
time[19] <- "Leonardo (São Paulo)"
time[20] <- "Branco (Fluminense)"
time[21] <- "Ronaldão (Shimizu S-Pulse)"

fimalgoritmo algoritmo "testandoVariaveis"
var
idades : vetor[1..10] de inteiro

inicio
fimalgoritmo Lógica de Programação Vetores Muitos valores Estruturas de dados homogêneas
(vetores) Enfim...
That's all folks! Os vetores possibilitam o armazenamento de valores do mesmo tipo dentro de uma única variável, dentro de um mesmo objeto ou contexto.

O acesso aos valores torna-se possível atraves de identificadores, de marcadores de posição ou indices. Armazenando dados... No desenvolvimento de programas de computadores é possível
armazenar dados em variáveis. Variáveis, o que são?
Variáveis lembram variar...
... mas variar o que? A definição mais simples para variável é:
Deve possuir um nome.
Deve possuir um tipo.
Deve possuir ou não um valor.

Em portugol a declaraçaõ de uma variável
pode ser expressa como abaixo: algoritmo "testandoVariaveis"
var
idade : inteiro
inicio
// códigos...
fimalgoritmo Uma variável armazena um valor apenas, mas e se fosse
necessário armazenar mais de um valor?

Uma resposta simples:
Podemos criar varias variáveis! algoritmo "testandoVariaveis"
var
idade1 : inteiro
idade2 : inteiro
idade3 : inteiro
inicio
fimalgoritmo Criar muitas variáveis é uma possível solução, mas será que
pode ser considerada a melhor?

O problema é que cada variável deve existir de forma única, com um proposito simples e objetivo.

O ideal é criar uma variável que tenha objetivo e que possua uma forma simples de acessar os valores.

Este modelo existe e chama-se Estrutura de dados homogênea, ou seja, um recipiente que possue varios valores do mesmo tipo e um unico ponto de acesso. Será que é bom criar muitas variáveis? algoritmo "testandoVariaveis"
var
idades : vetor[1..10]

inicio
fimalgoritmo Entendo a declaração dos vetores nome da variável Quantidade de
valores Tipo
de
dados Atribuindo valores... Posições Suponha que existe a necessidade de uma variável
que tenha o nome "time" e que receba como valores os nomes de todos os jogadores. Valores Dando continuidade ao exemplo anterior, precisamos agora acessar, ou descobrir, o nome de um jogadores do "time". Acessando valores... algoritmo "testandoVariaveis"

var
time : vetor[1..21] de caracter

inicio
time[1] <- "Taffarel (Reggiana)"
...
time[21] <- "Ronaldão (Shimizu S-Pulse)"

escreval("Jogador 1: ", time[1])

fimalgoritmo Posição Dando continuidade ao exemplo anterior, precisamos agora acessar, ou descobrir, o nome de todos od jogadores do "time". Acessando todos os valores... A variável indice é utilizada para acessar o nome do jogador algoritmo "testandoVariaveis"

var
time : vetor[1..21] de caracter
indice : inteiro
inicio
time[1] <- "Taffarel (Reggiana)"
...
time[21] <- "Ronaldão (Shimizu S-Pulse)"

para indice de 1 ate 21 faca

escreval(time[indice])

fimpara

fimalgoritmo Vetores nos auxiliam no armazenamento de
informações do mesmo tipo e mesmo contexto.
Full transcript