Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Programozási tételek

No description
by

Mónika Gál

on 7 December 2016

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of Programozási tételek

Programozási tételek
Egy sorozathoz Egy érték
Egy sorozathoz egy másik sorozat
Kiválogatás tétele
Metszetképzés
Unióképzés
Összefuttatás
Rendezések :
Rendezés közvetlen kiválasztással
Rendezés minimum kiválasztással
Buborékos rendezés
Egyszerű beillesztéses rendezés
Egy sorozathoz egy érték
Összegzés tétele
Eldöntés tétele
Kiválasztás tétele
Megszámlálás tétele
Keresések
Lineáris keresés tétele
Logaritmikus keresés tétele
Maximumkiválasztás tétele
Minimumkiválasztás tétele

Egy sorozathoz Egy Sorozat
Forrás: http://vasvill.hu/kerese/tetelek/index.htm
Összegzés tétele
Eldöntés tétele
Kiválasztás tétele
Megszámlálás tétele
Keresések
Maximumkiválasztás tétele
Minimumkiválasztás tétele
A kiválogatás tétele
Metszetképzés
Unióképzés
Összefuttatás
Rendezések
Eljárás:
S:=0
Ciklus I=1-től N-ig
S:=S+A(I)
Ciklus vége
Eljárás vége.
Eljárás:
I:=1
Ciklus amíg I<=N és A(I) nem T tulajdonságú
I:=I+1
Ciklus vége
VAN:=I<=N
Eljárás vége
Van-e a sorozatnak legalább egy T tulajdonságú eleme?
Eljárás:
I:=1
Ciklus amíg I<=N és A(I) T tulajdonságú
I:=I+1
Ciklus vége
IGAZ:=I>N
Eljárás vége
A sorozatnak minden eleme T tulajdonságú?
Hányadik indexű elem T tulajdonságú?
Eljárás:
I:=1
Ciklus amíg amíg I<=N és A(I) nem T tulajdonságú
I:=I+1
Ciklus vége
Ha I<=N SORSZ:=I
Különben SORSZ:=-1
Eljárás vége
Hány T tulajdonságú elem van?
Eljárás:
S:=0
Ciklus I=1-től N-ig
Ha A(I) T tulajdonságú akkor S:=S+1
Ciklus vége
Eljárás vége.
Lineáris keresés
Eljárás:
I:=1
Ciklus amíg I<=N és A(I) nem T tulajdonságú
I:=I+1
Ciklus vége
VAN:=I<=N
Ha VAN akkor SORSZ:=I
Eljárás vége.
Van-e T tulajdonságú elem, és ha igen, mi a sorszáma?
Logaritmikus keresés
Eljárás:
Al:=1
F:=N
Ciklus
K:=INT((Al+F)/2)
Ha A(K)<X akkor Al:=K+1
Ha A(K)>X akkor F:=K-1
amíg Al<=F és A(K)!= X (amíg Al>F vagy A(K)=X)
Ciklus vége
VAN:=Al<=F
Ha VAN akkor SORSZ:=K
Eljárás vége.
Keresés rendezetlen sorozatban
(Eldöntés és kiválasztás együtt)
Keresés rendezett sorozatban
Eljárás:
INDEX:=1
Ciklus I=2-től N-ig
Ha A(INDEX) < A(I) akkor INDEX:=I
Ciklus vége
Eljárás vége.
A sorozat legnagyobb elemének indexe
Eljárás:
ÉRTÉK:=A(1)
Ciklus I=2-től N-ig
Ha A(I) < ÉRTÉK akkor ÉRTÉK:=A(I)
Ciklus vége
Eljárás vége.
A sorozat legkisebb elemének indexe
Eljárás:
J:=0
Ciklus I=1-től N-ig
Ha A(I) T tulajdonságú, akkor J:=J+1
B(J):=I
Ciklus vége
Eljárás vége.
Egy N elemű sorozat összes T tulajdonságú elemét kell meghatározni.
A kiválogatott elemek sorszámait egy B() vektorban gyűjtjük.
Eljárás:
CN:=0
Ciklus I=1-től N-ig
J:=1
Ciklus amíg J<=M és A(I)<>B(J)
J:=J+1
Ciklus vége
Elágazás Ha J<=M akkor
CN:=CN+1
C(CN):=A(I)
Elágazás vége
Ciklus vége
Eljárás vége.
Egy új tömbbe (C) gyűjtsük ki azokat az elemeket, amelyek mindkét tömbben szerepelnek.
Eljárás:
Ciklus I=1-től N-ig
C(I):=A(I)
Ciklus vége
CN:=N
Ciklus J=1-től M-ig
I:=1
Ciklus amíg I<=N és A(I)<>B(J)
I:=I+1
Ciklus vége
Elágazás Ha I>N akkor
CN:=CN+1
C(CN):=B(J)
Elágazás vége
Ciklus vége
Eljárás vége.
Hozzunk létre egy új (C) tömböt, amelybe minden elemet beleteszünk, amely A-ban vagy B-ben szerepelt. A mindkét tömbben meglévő elemek csak egyszer kerüljenek bele C-be.
Eljárás:
I:=1
J:=1
K:=0
Ciklus amíg I<=N és J<=M
K:=K+1
Elágazás
A(I) < B(J) esetén C(K):=A(I)
I:=I+1
A(I) = B(J) esetén C(K):=A(I)
I:=I+1
J:=J+1
A(I) > B(J) esetén C(K):=B(J)
J:=J+1
Elágazás vége
Ciklus vége
Ciklus amíg I<=N
K:=K+1
C(K):=A(I)
I:=I+1
Ciklus vége
Ciklus amíg J<=M
K:=K+1
C(K):=B(J)
J:=J+1
Ciklus vége
Eljárás vége.
Két rendezett sorozat uniója úgy, hogy a rendezettség megmaradjon.
Eljárás:
Ciklus I=1-től N-1-ig
Ciklus J=I+1-től N-ig
Ha A(J) < A(I) akkor C:=A(J)
A(J):=A(I)
A(I):=C
Ciklus vége
Ciklus vége
Eljárás vége.
Rendezés közvetlen kiválasztással
Első menetben az A(1)-et összehasonlítjuk az összes elemmel és ha kisebbet találunk nála, akkor felcseréljük. Ezután A(2)-vel tesszük ugyanezt
Eljárás:
Ciklus I=1-től N-1-ig
INDEX:=I
ÉRTÉK:=A(I)
Ciklus J=I+1-től N-ig
Ha A(J)<ÉRTÉK akkor ÉRTÉK:=A(J)
INDEX:=J
Ciklus vége
A(INDEX):=A(I)
A(I):=ÉRTÉK
Ciklus vége
Eljárás vége.
Rendezés minimumkiválasztással
Nem cserélünk feleslegesen, hanem megjegyezzük a legkisebb elem indexét.
Eljárás:
Ciklus I=2-től N-ig
Ciklus J=N-től I-ig -1-esével
Ha A(J-1)>A(J) akkor Cs:=A(J-1)
A(J-1):=A(J)
A(J):=Cs
Ciklus vége
Ciklus vége
Eljárás vége.
Buborékos rendezés
Vektor végéről indulva minden elemet összehasonlítunk az előtte lévővel.
Ha rossz a sorrend, akkor csere. (Cs=cserehely)
Az első menet végére az első helyen a megfelelő elem áll.
Ezt az elvet folytatjuk egyre kevesebb elemmel. (N-1 menet)
Eljárás:
Ciklus J=2-től N-ig
I:=J-1
A:=A(J)
Ciklus amíg I > 0 és A < A(I)
A(I+1):=A(I)
I:=I-1
Ciklus vége
A(I+1):=A
Ciklus vége
Eljárás vége.
Beillesztése rendezés
Az aktuális elemet hasonlítjuk mindig az előtte levőkkel, ha rossz a sorrend az elől levőket eggyel előrébb toljuk, és az aktuálisat beillesztjük a megfelelő helyre.
Full transcript