Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Make your likes visible on Facebook?

Connect your Facebook account to Prezi and let your likes appear on your timeline.
You can change this under Settings & Account at any time.

No, thanks

Excel 2010 Alapszint 2 - Függvények

No description
by

Eva Viktoria Szabo

on 6 October 2015

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of Excel 2010 Alapszint 2 - Függvények

Tematika
függvények szintaxisa
fogalmak tisztázása
3 féle megközelítési mód
másolás és beillesztés
függvénytípusok áttekintése
tippek és trükkök

Excel 2010
Alapszint 2
Függvények

Fogalmak
Függvények használata
Másolás és beillesztés
Függvény kategóriák
Matematikai
Statisztikai
Logikai
Dátum és idő
Szöveg
Egyéb (Keresés, Pénzügyi, Műszaki, Kocka, Információ, Kompatibilitás)
Tippek és trükkök
Függvények szintaxisa
=függvénynév(argumentum)
függvény
=
a függvény mindig ezzel kezdődik
SZUM
függvénynév
szum
(A1:A2)
argumentum
mindig zárójelek közé írandó
Argumentum
Típusok
Tulajdonságok
nem minden függvénynél kötelező, de () akkor is kell
Érték
Tartomány
Hivatkozás
egyszerű, bevitt adatok
cellaformátummal állíthatjuk át a típusát
a függvényben csak akkor változik, ha kézzel átírjuk
szám - 3
szöveg - ez egy szöveg
dátum - 2014.01.01
stb.
két dátum különbsége
(azaz eltelt napok száma)
sokszor dátumként jelenik meg
érték
tartomány
hivatkozás
2014.01.01
$A2
$A$2
A2
3
szöveg
A1:A10
A1:F1
ha több van pontosvesszővel ; kell elválasztani őket
=SZUM(3;2)
=MA()
=1+1
1+1
vs
"bal felső" és "jobb alsó" cellák neve kettősponttal elválasztva
A1:F1
A1;F4
A1:F4
ez NEM tartomány
A1:A4
Relatív
Abszolút
Vegyes
munkalap
celláját
vagy
tartományát
azonosítja
a használni kívánt érték vagy adat helyét határozza meg
a hivatkozott cella és a képletet tartalmazó cella közötti relatív elhelyezkedésen alapul
ha a képletet tartalmazó cella helye változik, a hivatkozás is változik
ha átmásoljuk a képletet tartalmazó cellát, akkor a hivatkozás is automatikusan igazodik az új helyhez
ez az alapértelmezett hivatkozástípus
=A1
=A1 képlet D1 cellából
D2 cellába történő másolása után D2 automatikusan =A2 függvényt fogja tartalmazni
=$A$1
adott helyen található cellára mutat
ha a képletet tartalmazó cella helye változik, az abszolút hivatkozás változatlan marad
ha a képletet másoljuk, az abszolút hivatkozás nem igazodik az új helyhez
=$A$1 képlet D1 cellából
D2 cellába történő másolása után D2 is =$A$1 függvényt fogja tartalmazni
=$A1
=A$1
1. oszlop abszolút és a sor relatív
2. oszlop relatív és a sor abszolút
ha a képletet tartalmazó cella helye változik, akkor a relatív hivatozás módosul, míg az abszolút nem
ha a képletet tartalmazó cellát másoljuk, akkor a relatív hivatkozás automatikusan igazodik, míg az abszolút változatlan marad
Abszolút oszlop és relatív sor
=$A1
=$A1 képlet D1 cellából
E2 cellába történő másolása után E2 =$A2 függvényt fogja tartalmazni
Relatív oszlop és abszolút sor
=A$1
=A$1 képlet D1 cellából
E2 cellába történő másolása után E2 =B$1 függvényt fogja tartalmazni
Szakasz1.xlsx
Hivatkozás munkalapra
='Munkalap neve'!A1
átmásolja a Munkalap neve elnevezésű munkalap A1 cellájában található értéket vagy adatot
1. kattintsunk a cellába
2. írjuk be a szerkesztőlécbe =
3. kattintsunk a kiválasztott munkalap másolni kívánt cellájára
4. nyomjuk meg az Enter bellentyűt vagy a pipát a szerkesztőlécen
3 megközelítési mód
1. menüszalag segítségével
2. Függvény beszúrása funkció
3. szerkesztőléc segítségével
Menüszalag segítségével
5 leggyakrabban használt függvény
(általában) automatikusan kijelöli a tartományt
alapértelmezetten relatív hivatkozásokat tartalmaz
előnye: könnyen elérhető, kevés a hibalehetőség
hátránya: automatikus kijelölés, hivatkozástípus javítása
Tulajdonságok
Használata
1. cellába áll (ahova a függvényt szeretnénk beszúrni)
2. elérése
Kezdőlap > Szerkesztés > függvény kiválasztása
Képletek > Függvénytár > AutoSzum
3. argumenum kiválasztása
tartomány: bal egérgombot nyomva tartva
hivatkozások: bal egérgombbal kattintva + Ctrl billentyűt nyomva tartva
4. Enter billentyű megnyomása vagy a szerkesztőlécen található pipára kattintás
Függvény beszúrása
függvény keresés
kategóriák böngészése
(kategóriákról később)
függvények listája
argumentumok kiválasztása
függvény alkalmazása
szöveges segédlet
"előnézet"
váltás a tartomány kiválasztása nézetre
Tulajdonságok
az összes függvény használható
(általában) automatikusan kijelöli a tartományt
alapértelmezetten relatív hivatkozásokat tartalmaz
előnye: tele van segédlettel, kevés a hibalehetőség, bonyolult függvényeknél ajánlott a használata
hátránya: sok lépésből áll, hivatkozástípus javítása
Használata
1. elérése:
AutoSzum > További függvények
Képletek > Függvény beszúrása
szerkesztőléc > Függvény beszúrása gomb
2. válasszuk ki a használni kívánt függvényt, majd nyomjuk meg az Ok gombot
3. válasszuk ki a függvény argumentumát, majd nyomjuk meg a Kész gombot
függvény kiválasztása
automatikusan kijelölt tartomány ellenőrzése
hivatkozástípus javítása
tartomány kijelölése
egérrel
vissza az előző nézethez
Szerkesztőléc segítségével
Tulajdonságok
függvény bevitele általában kézileg történik
rögtön megadhatjuk a hivatkozás típusát
itt is van segédlet
előnye: gyors
hátránya: nagyobb a hibalehetőség, ezért egyszerűbb függvényeknél vagy haladóknak ajánlott
Használata
1. szerkesztőlécben vagy a cellában = jellel írandó
2. függvényneve kis vagy nagy betűvel
3. zárójel (és ha szükséges bele az argumentum)
4. Enter billentyű vagy szerkesztőlécen található pipa megnyomása
Függvények módosítása
függvények módosítására mindhárom megközelítési módban van lehetőség
menüszalagos
: válasszuk ki a használt függvényt és módosítsuk az argumentumokat
beszúrásos
: a már megismert módszerek valamelyikével hívjuk elő a Függvényargumentumok ablakot, ahol módosíthatjuk a tartományt vagy a hivatkozást
szerkesztőléces
: a szerkesztőlécbe állva kézileg begépelve vagy egérrel bekattintva módosíthatjuk az argumentumokat
Szakasz2.xlsx
Kitöltés, automatikus kitöltés, másolás, Ctrl + C a függvényeknél is működik
Relatív hivatkozás: másoláskor automatikusan módosul
Abszolút hivatkozás: másoláskor változatlan marad
Mi van, ha nem a függvény, hanem az kiszámított érték másolására van szükségem?
Irányított beillesztés
Tulajdonságok
Megadhatjuk, hogy mit szeretnénk másolni
Másolás után történik a kiválasztás
Alapértelmezetten minden másolódik (képlet, formátum, formázás)
Használata
1. Jelöljük ki a másolni kívánt értéket, tartományt.
2. Álljunk a beillesztésre szánt terület bal felső cellájába.
3. Nyomjuk meg a jobb egérgombot.
4. Válasszuk ki a megfelelő lehetőséget.
Irányított beillesztés típusai
Beillesztés
: alapértelmezett, mindent átvisz
Képletek
: csak a képletet illeszti be
Képletek és számformátum
: képletet és a számformátumot illeszti be
Értékek
: a másolt függvény értékét illeszti be
Értékek és számformátum
: kiszámított értéket és a számformátumot illeszti be
Értékek és forrásformátum
: kiszámított értéket, formátumot és formázást illeszti be
Csatolt beillesztés
Csatolt beillesztés
Ilyen módon is hivatkozhatunk egy másik cellára, munkalapra és munkafüzetre
Használata
Megegyezik az irányított beillesztéssel
Szakasz3.xlsx
Szakasz3.xlsx
Matematikai
=SZUM(argumentum1;
argumentum2;...
)
=SZORZAT(argumentum1;
argumentum2;...
)
értékek, hivatkozások és tartományok összeadása
SZUM vs +
=SZUM(A1:A7;B1:B7) inkább tartományok összeadása
=A1:A7+B1:B7 inkább értékek, hivatkozások összeadása
értékek, hivatkozások és tartományok összeszorzása
SZORZAT vs *
=SZORZAT(A1:A7;B1:B7) inkább tartományok szorzata
=A1:A7*B1:B7 inkább értékek, hivatkozások szorzata
Szakasz4.xlsx
Dátum és idő
=MA()
=NAP360(kezdődátum;befejeződátum)
bármikor nyitjuk meg a munkafüzetet, mindig az aktuális dátumot írja ki
dátum ellenőrzéseknél hasznos
nincs argumentuma
két dátum között eltelt időt adja meg
360 napos évvel számol (12 hónap * 30 nap)
ha pontosabb eredményt szeretnénk, használjuk az alábbit (de figyeljünk a sorrendre!):
=befejeződátum-kezdődátum
Szakasz5.xlsx
Szöveg
=ÖSSZEFŰZ(argumentum1;argumentum2;...)
argumentum lehet szöveg, szám és hivatkozás, de tartomány nem
ha argumentumként szöveget adunk meg, mindig tegyünk "" közé
az ÖSSZEFŰZ függvényen kívül a & jelet is használhatjuk
=ÖSSZEFŰZ(1;" alma") 1 alma
=1&" alma" 1 alma

sok elem esetén az ÖSSZEFŰZ függvény használata ajánlott, mert átláthatóbb
=ÖSSZEFŰZ(A1;" ";A2;" ";A3;" ";A4;" ";A5)
=A1&" "&A2&" "&A3&" "&A4&" "&A5
Szakasz6.xlsx
Logikai
=HA(logikai_vizsgálat;érték_ha_igaz;érték_ha_hamis)
Szakasz7.xlsx
Statisztikai
=ÁTLAG(argumentum1;
argumentum2;...
)
=MIN(argumentum1;
argumentum2;...
)
=MAX(argumentum1;
argumentum2;...
)
Szakasz8.xlsx
Tartományhivatkozás "extrém" módon
Egész oszlop kijelölése
=SZUM(A:A) összeadja az A oszlop összes értékét
Több teljes oszlop kijelölése
=SZUM(A:B) összeadja az A és B oszlop összes értékét
Egész sor kijelölése
=SZUM(1:1) összeadja az 1. sor összes értékét
Több teljes sor kijelölése
=SZUM(1:2) összeadja az 1. és 2. sor összes értékét
Hibakódok
#NULLA!
#ZÉRÓOSZTÓ!
#ÉRTÉK!
#HIV!
#NÉV?
#SZÁM!
#HIÁNYZIK
pl. hibásan megadott tartomány
nullával vagy üres cellával történő osztás
nem megfelelő típusú argumentum
érvénytelen hivatkozás
képletben szereplő szöveg nem ismerhető fel
érvénytelen számérték szerepel a képletben
nem áll rendelkezésre a képletben szereplő érték
Függvény módosítási tippek
Ízelítő a középszintből
Matematikai - SZUMHA
Statisztikai - DARABTELI
Keresés - FKERES
a megadott feltételnek eleget tevő cellákban található értékeket adja össze
Szintaxis:
=SZUMHA(kiértékelési_tartomány;feltétel;összegzési_tartomány)
a tartományban összeszámolja azokat a cellákat, amelyek megfelelnek megadott feltételnek
Szintaxis:
=DARABTELI(tartomány;feltétel)
egy keresett érték megadott tartományban szereplő sorának bármely celláját adja eredményül
Szintaxis:
=FKERES(keresett_érték;tartomány;oszlop_száma;
tartomanyban_keres
)
Módosítás
dupla kattintás a cellára
kattintás a szerkesztőlécbe
F2
menüszalagon
Módosítás befejezése
Enter
pipa a szerkesztőlécen
kattintás másik cellára
lépkedés nyíllal
Cella hivatkozás átalakítása abszolút hivatkozássá
kézzel beírás (AltGr + É)
F4
Képletek megjelenítése (értékek helyett)
menüszalag > Képletek > Képlet vizsgálat > Képletek
argumentumként megadott értékek átlagát számolja ki
argumentum lehet szám, hivatkozás és tartomány
csak az első argumentum megadása kötelező
argumentumként megadott értékek maximumát adja meg
használata megegyezik a MIN függvénnyel
argumentumként megadott értékek minimumát adja meg
argumentum lehet szám, hivatkozás és tartomány
csak az első argumentum megadása kötelező
logikai_vizsgálat
kötelező megadni
olyan kifejezés, aminek kiértékeléskor IGAZ vagy HAMIS lesz az eredménye
érték_ha_igaz
ez az érték jelenik meg, ha
"logikai_vizsgálat"
eredménye IGAZ
érték_ha_hamis
ez az érték jelenik meg, ha
"logikai_vizsgálat"
eredménye HAMIS
Logikai vizsgálat - Operátorok
<> nem egyenlő
< kisebb
<= kisebb vagy egyenlő
> nagyobb
>= nagyobb vagy egyenlő
= egyenlő, azonos
1=1 IGAZ
1=2 HAMIS
"a"="a" IGAZ
"a"="b" HAMIS
1<>1 HAMIS
1<>2 IGAZ
"a"<>"a" HAMIS
"a"<>"b" IGAZ
1<1 HAMIS
1<2 IGAZ
"a"<"a" HAMIS
"a"<"b" IGAZ
1>1 HAMIS
2>1 IGAZ
"a">"a" HAMIS
"b">"a" IGAZ
1<=1 IGAZ
2<=1 HAMIS
"a"<="a" IGAZ
"b"<="a" HAMIS
1>=1 IGAZ
1>=2 HAMIS
"a">="a" IGAZ
"a">="b" HAMIS
$
AltGr + É
Full transcript