Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Make your likes visible on Facebook?

Connect your Facebook account to Prezi and let your likes appear on your timeline.
You can change this under Settings & Account at any time.

No, thanks

Algoritmos y Problemas

No description
by

Pablo Moreira

on 9 March 2015

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of Algoritmos y Problemas

Problemas y Algoritmos
Conjunto de pasos o acciones que
solucionan un problema
Algoritmo
Características
Preciso: Pasos claros y sin ambigüedad.
Determinista: A = entrada = resultado.
Finito : Debe terminar.
Todo algoritmo debe resolver un problema de forma general.
Ordenar listas de números
25,4,65,1...n
3,6,21,8....n
-2,3,4,5..n
-2,3,8,1,2,0...n
Problema
Situación que se presenta
Resolver Problemas
Análisis
Algoritmo
Codificar
Aunque parezca obvio, resolver problemas implica pensar
Programar
Es una ciencia
Escribir Algoritmos
Diagramas de flujo
Diagrama de flujo
Método esquemático para implementar algoritmos
Pseudocódigo
Variables
10101111
00000000
00011010
01101011
Memoria
variable1

variable2

variable3
0
26
107
00011010
01101011
+
10000101
133
10101111
10000101
00011010
01101011
variable1 = variable2 + variable3
133 26 107
Memoria
Las variables nos permiten guardar datos en la memoria
Permite modelar un proceso para analizar un problema
Por ser gráfico es mas fácil de interpretar
Primer Diagrama
Nombre
Salida
Fin
Entrada Salida de Datos
Periféricos
Diagrama simplificado
Proceso
Fuerza
Distancia
Tiempo
Temperaturas
Corriente
Tensión
on/off
Si/No
0/1
5V/0V
Asignación
Guardamos el valor 1 en memoria.
Asignación
11
Ejercicio Asignación
Diseñar un algoritmo que convierta temperatura de grados Fahrenheit a Celsius
Cº = (
ºF
- 32) * 10/18
Solución Propuesta
Entrada
Proceso
Salida
Decisión
Existen estructuras selectivas o de decisión que permite alterar el flujo de un algoritmo
Si
SI NO
Ejercicio SI SINO
Diseñar un algoritmo que convierta grados Fº a Cº y que muestre un mensaje dependiendo del valor. Si la temperatura en Cº > 27 escribir "Hace calor", Si no Escribir "Puede hacer frío".
Ejercicio SI SINO 2
Diseñar un algoritmo que convierta grados Fº a Cº y que muestre un mensaje dependiendo del valor. Si la temperatura en Cº > 27 escribir "Hace calor", si es < 16 "Hace frío". Si no se cumplen las anteriores condiciones, escribir la "temperatura es agradable".
Estructuras Repetitivas
Sirven para alterar el curso de un algoritmo tantas veces como se quiera.
También se conocen como estructuras iterativas.
Cada repetición es un iteración.
Mientras y Para
Mientras
Para
Ejercicio Mientras
Diseñar un algoritmo que sume los números desde 1 hasta n usando Mientras.
Suma = 1 + 2 + 3 + 4 ...... + n-1 + n
No se puede usar la formula de Gauss
Suma = n(n+1)/2
Ejercicio Para
Diseñar un algoritmo que sume los números desde 1 hasta n usando Para.
Pseudocódigo
Es una aproximación a un lenguaje de programación.
Tiene los mismos elementos que los diagramas.
Tienen reglas a igual que los diagramas.
Estas reglas son sintácticas.
Primer Pseudocódigo
1 Proceso HolaMundo
2 Escribir "Hola Mundo"
3 FinProceso
Nombre
Salida
Fin
Entrada y Salida de Datos
1 Proceso HolaMundo
2 Leer variable
3 Escribir variable
4 FinProceso
Entrada
Salida
Pseudocódigo Simpleficado
1 Proceso HolaMundo
2 Leer varible
3 Proceso variable
4 Escribir variable
5 FinProceso
Operamos con
las variable
Asignación
1 Proceso HolaMundo
2 varible <- 1
3 Escribir variable
4 FinProceso
Guardamos el valor 1
1 Proceso HolaMundo
2 var1 <- 1
3 var2 <- var1 + 10
4 Escribir var1
5 FinProceso
11
Solución
Si
Si SiNO
Mientras
Para
Determinar el método que hay que seguir para obtener un resultado esperado.
Se conoce o no la solución
Solución
Codificar
Es programar o escribir un programa
Necesitamos conocer un lenguaje
Algoritmo
Código
Solución
Problema
Se hace en computadoras u otros dispositivos
Es un arte
Full transcript