Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Programozási módszerek 1. óra

No description
by

Mónika Gál

on 15 December 2016

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of Programozási módszerek 1. óra

Alapfogalmak
Programozás
Algoritmus
Programkód

Programozási módszerek 1. óra
A strukturális programozás alapelemei:
Vezérlési szerkezetek
szekvencia
elágazás
ciklus
Programnyelv: C#
2002-ben jelent meg a Visual Studio.NET programcsomag részeként
C, C++ nyelv: hatékony, de komplexitása miatt hosszabb a fejlesztési idő
Olyan programozási nyelvre van szükség, amely megtartja a hatékonyságot, de lerövidül a fejlesztési ciklus
C#=C++ hatékonysága+Visual Basic produktivitása
Főbb adattípusok
Egész (int)
Lebegőpontos (float, double)
Karakter (char)
Logikai (bool)
Szöveg (String)
Változók, konstansok értékadás, kiiratás
Témakörök és aláírás-feltételek
Programozás
Feladatleírás alapján a megoldás tervének elkészítését, finomítását, valamint a terv alapján történő megvalósítást foglalja magában.
Algoritmus
"a megoldás menete"
Olyan megengedett lépésekből álló útmutatás, amely alapján megoldható a felmerült probléma.
Leírása lehetséges:
Természetes nyelven
Folyamatábrával
Pszeudo-kóddal
Struktogrammal
Jackson diagrammal
Rántotta készítés algoritmusa természetes nyelven
1. Vedd elő a serpenyőt
2. Tegyél bele olajat
3. Vegyél elő tálat
4. Tegyél bele x tojást
5. Verd fel a tojásokat
6. Sózd meg
7. Gyújtsd meg a gázt
8. Ha forró az olaj, öntsd a serpenyőbe a tojásokat
9. Kevergesd fakanállal, amíg meg nem sül

Rántotta készítés algoritmusa pszeudo-kóddal
Vedd elő a serpenyőt
Tegyél bele olajat
Vegyél elő egy tálat
Ciklus
i
:=
1..x
Törd fel a tojást
Öntsd a tálba
Ciklus vége
Verd fel a tojásokat
Sózd meg
Gyújtsd meg a gázt
Ha
forró az olaj
Akkor
Öntsd a serpenyőbe a tojásokat
Ciklus amíg
meg nem sül
Kevergesd fakanállal
Ciklus vége

Rántotta készítés algoritmusa folyamatábrával
Programkód
A programkód az ember által olvasható és értelmezhető utasítások sorozata, amellyel közölhetjük a számítógéppel egy adott feladat elvégzésének módját.
Szekvencia
A programban a részfeladatok egymás után (felülről lefelé) hajtódnak végre.
Például:
Program
Áfaszámítás
Be:
nettoAr
afaKulcs
:=
0,27
afa
:=
nettoAr*afakulcs
bruttoAr
:=
nettoAr+afa
Ki
: afa
Ki:
bruttoAr
Program vége
Elágazás
Egy megadott feltételtől függ a végrehajtandó utasítás.
Program
NegatívVagyPozitív
Be:
szam
Ha
szam>0
Akkor Ki:
A szám nullánál nagyobb.
Különben Ki:
A szám nem nagyobb mint 0.
Program vége
Ciklus
Program
Elso10pozitivSzamOsszege
osszeg
:=
0
Ciklus
i
:=
1..10
osszeg
:=
osszeg+i
i:=i+1
Ciklus vége
Ki:
osszeg
Program vége
Számlálós
Előltesztelő
Program
Elso10pozitivSzamOsszege
osszeg
:=
0
i:=1
Ciklus

amíg
i<=10
osszeg
:=
osszeg+i
i:=i+1
Ciklus vége
Ki:
osszeg
Program vége
Program
Elso10pozitivSzamOsszege
osszeg
:=
0
i:=1
Ciklus
osszeg
:=
osszeg+i
i:=i+1
amíg
i<=11
Ciklus vége
Ki:
osszeg
Program vége
Hátultesztelő
Változó deklarálása:
int szam;
int szam=5;
int szam1,szam2;
Konstans deklarálása:
const int pi=3.14;
Operátorok
Aritmetikai operátorok
* Szorzás
/ Osztás
% Maradékképzés
+ Összeadás
- Kivonás
>> bitenkénti jobbra léptetés
<< bitenkénti balra léptetés

Összehasonlító operátorok
< <= > >= ==
!= Nem egyenlő
Sztringoperátorok:
+ Sztringösszefűzés

Értékadó operátorok
= Értékadás
*= Szorzás és értékadás
/= Osztás és értékadás
+= Összeadás és értékadás
-= Kivonás és értékadás


Logikai operátorok
&&
||
Webes segédanyag: http://www.fuvesi.com/csharp/
Beolvasás és kiiratás:
String nev;
nev=System.Console.ReadLine();
String nagyBetusNev=nev.ToUpper();
System.Console.WriteLine("Név nagybetűkkel:");
System.Console.WriteLine(nagyBetusNev);
Ismerkedés a Visual Studio-val
Console Application készítése
Kérjük be a felhasználó vezeték és keresztnevét, és fűzzük azokat egy stringbe, majd írjunk üdvözlő szöveget a felhasználónak az összefűzött stringet felhasználva.
Olvassunk be két egész számot a billentyűzetről, számoljuk ki az összegüket, és irassuk ki a képernyőre az eredményt.
Kérjük be a felhasználótól egy árucikk nettó értékét, számítsuk ki az áfáját és a bruttó értékét, majd irassuk ki a képernyőre az eredményt.
Kérjük be a felhasználótól a kör sugarát, számítsuk ki a kör területét és kerületét, majd irassuk ki a képernyőre az eredményt.
Kérjük be a felhasználótól egy másodfokú egyenlet együtthatóinak értékeit, számítsuk ki a megoldásokat és irassuk ki a képernyőre az eredményt.
Math.Sqrt()
Ismerkedés a Visual Studio-val
Windows Forms Application készítése
Oldjuk meg a korábbi feladatokat ablakos felületen is. Használjuk a TextBox, Button és Label komponenseket!
Inicializálás
További gyakorló feladatok
Írj programot, amely beolvas két számot, és eredményül visszaadja az osztás után az egész részt és a maradékot (%).
Írj programot, amely beolvassa egy gömb sugarát, és kiírja a felszínét és térfogatát
Írj programot, amely bekéri egy derékszögű háromszög befogóinak értékeit, és kiszámolja az átfogó hosszát.
Olvassunk be egy hőmérséklet-értéket Celsiusban, váltsuk át Farenheitre és írjuk ki a képernyőre.
http://progalap.elte.hu/downloads/seged/eTananyag/lecke4_lap1.html#hiv3
http://monsooninfo.blog.hu/2015/05/31/15_meno_oktatojatek_hogy_megtanulj_programozni
Full transcript