Loading presentation...

Present Remotely

Send the link below via email or IM

Copy

Present to your audience

Start remote presentation

  • Invited audience members will follow you as you navigate and present
  • People invited to a presentation do not need a Prezi account
  • This link expires 10 minutes after you close the presentation
  • A maximum of 30 users can follow your presentation
  • Learn more about this feature in our knowledge base article

Do you really want to delete this prezi?

Neither you, nor the coeditors you shared it with will be able to recover it again.

DeleteCancel

Make your likes visible on Facebook?

Connect your Facebook account to Prezi and let your likes appear on your timeline.
You can change this under Settings & Account at any time.

No, thanks

Simpson 3/8

No description
by

Diego Cortés Rodriguez

on 3 September 2013

Comments (0)

Please log in to add your comment.

Report abuse

Transcript of Simpson 3/8

Simpson 3/8
Simpson 3/8
El método de Simpson 3/8 es un método de integración numérica
Ejemplo
ALGORITMO
Integrando por el método del Simpson 3/8 compuesto.
En primer lugar se verifica que el valor de “n” (5), tampoco es múltiplo de 3, por lo que no se
podría aplicar el método. Pero se puede dividir la integral y aplicar distintos métodos en los intervalos.
Determina o aproxima el área bajo una función de tercer grado que conecta 4 puntos sobre una curva dada de una integral definida
Para hallar los valores de Xk+1 y Xk+2
Debemos hallar el valor de h que es: (a-b)/3 donde a y b son los limites de la integral; entonces:
X1: a+h
X2: x1+h
Para Usar este Metodo
Debemos dividir el intervalo de la integral en 4 partes iguales delimitadas por los limites de la integral que son :
a y b; Si estos valores no existen este método no podrá ser utilizado
Existen 2 Tipos de integración por Simpson 3/8
Una simple y Una Compuesta (para n Puntos)
Simpson 3/8 Simple
Presentado por:
Diego Cortés Rodriguez
Tony Ccorimanya Licona
Frank Velarde Ramirez
Brajean Arce Uscachi

En este tipo
Los valores de Xk y Xk+3 son conocidos: son los limites de la integral a y b
La formula para este tipo es:
Hallar "h"
Donde "a" y "b" serán los limites de la integral y "n" sera el numero de divisiones que debe tener el intervalo el cual siempre sera 3
Simpson 3/8 Compuesto
Este tipo de integración numérica se usa cuando el area debajo de la parábola ya se encuentra dividida en "n" divisiones todas de la misma anchura
La formula de este tipo de integración es:
Donde:

Simpson 3/8 Simple
Modulo Principal
Inicio
//Ingresar los limites
Leer a
Leer b
//Calculo de H
H = b - a/3
//Calculo de los puntos de integracion
X0 = a
X1 = X0 + H
X2 = X1 + H
X3 = X2 + H
//Calculo de I
I = (3 * H/8) * (FuncionSimple(X0) + (3 * FuncionSimple(X1)) + (3 * FuncionSimple(X2)) + FuncionSimple(X3))
Escribir I
Fin

Modulo double FuncionSImple(double X)
Inicio
retornar X³/1 + √X
Fin
Integrando por el método de Simpson 3/8.
Se utilizan las siguientes formulas:

Simpson 3/8 Compuesto
Modulo Principal
Inicio
//Ingresar los limites
Leer a
Leer b
//Ingresar el numero de intervalos
Leer n
//Calculo de los puntos de integracion
[]X = nuevo [n + 2] //Puntos de integracion
[]R = nuevo [n + 2] //Calculo de puntos en la ecuacion
para(i = 0; i < n; i++)
Inicio_para
X0 = a
X[i + 1] = X[i] + H
R[i] = (1/√2 * ¶) * e ^ -X[i] * X[i]/2
Fin_para
I = (3 * H/8) * (R[0] + 3 * aux1(R, n) + 3 * aux2(R, n) + 2 * aux3(R, n) + R[n])
Escribir(I)
Fin_Modulo Principal
Luego la formula sería:
Reemplazando la tabla de datos:
//Modulos auxiliar
Modulo double aux1(R, n)
inicio
tem1 = 0
para(i = 1; i <= n - 2; i=+3)
Inicio_Para
tem1 += R[i]
Fin_Para
retornar tem1
Fin_Modulo aux1
Modulo double aux2(R, n)
Incio
tem 2 = 0
para(i = 2; i <= n - 1; i = i + 3)
Inicio_para
tem2 += R[i]
Fin_para
Fin_Modulo aux2
Retornar tem2
Modulo double aux3(R, n)
Inicio
tem3 = 0
para(i = 0; i <= n - 3; i = i + 3)
inicio_para
tem3 += R[i]
Fin_para
retornar tem3
FIn_Modulo aux3
Full transcript